discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: New user, Focus issues


From: Michael Reid
Subject: Re: New user, Focus issues
Date: Tue, 21 Jun 2005 15:54:58 -0500

Hi,

It seems I've solved my own problem. Turns out that I had been launching gnome-settings-daemon from before I began using GNUstep. This seemed to be the culprit, no more sticky Mod issues.

/mike

On 2005-06-21 14:50:59 -0500 Michael Reid <address@hidden> wrote:

Hi,

I am having one problem though. There seems to be some focus issues with keyboard shortcuts. Maybe this is a window manager thing, but I'm using WindowMaker which I expect would play nice w/ GNUstep. Anyhow, the problem is this: When I use a shortcut (e.g. Mod-c for copy) then the window that has focus no longer responds to keyboard input. Usually this can be solved by giving another window focus and then coming back, but sometimes its really stubborn and I have to go through some sequence of random events in order to get the window to accept keyboard input again.

Does anyone have any idea what could be causing this? I don't expect this to be an app-specific problem, as it occurs with TextEdit, Addresses, GNUMail, and others.

I am using manual (click-to-focus) with WindowMaker, as I found that focus-follows-mouse caused even more problems.

Hm, strange...which version of WindowMaker are you using?


WindowMaker 0.91 with GNUstep-startup-0.11.0.

It appears that the "Mod" key is sticking. For example, if I hit Mod-c, and then let go and then hit v it will paste. Anything I hit after Mod is interpreted as Mod-<anything>. It seems that in most cases I can unstick Mod by hitting Ctrl.

I must have some wonky setting somewhere that is doing this.

/mike



_______________________________________________
Discuss-gnustep mailing list
address@hidden
http://lists.gnu.org/mailman/listinfo/discuss-gnustep






reply via email to

[Prev in Thread] Current Thread [Next in Thread]