[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Gorm on Mac OS 10.4.2?

From: Yves de Champlain
Subject: Re: Gorm on Mac OS 10.4.2?
Date: Fri, 23 Sep 2005 15:55:33 -0400

I have tried it today with the last patch Adam committed yesterday. Now everything is compiling correctly, however it is still impossible to launch any application because a segmentation fault occurs when a bundle is loaded… This issue has been mentionned on this list iirc. Few months ago I have been able to successfully compile GNUstep on Mac OS X 10.4, but I stumbled exactly on this issue : many classes with no name seems to be loaded, when the symbol hash is computed, a segmentation fault occurs. I must say I have been unable to fix it by myself.


I don't know how it used to work, but could it be related to the linking of bundles using "ld -bundle" ?

every gnustep apps I tried all (except the tools from gnustep-base) crash in libobjc.A.dylib (Apple's runtime) even though otool reveals no such dependency


reply via email to

[Prev in Thread] Current Thread [Next in Thread]