[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Csh users ? [was Re: GNUSTEP_USER_ROOT?]

From: Dirk Olmes
Subject: Re: Csh users ? [was Re: GNUSTEP_USER_ROOT?]
Date: Wed, 19 Oct 2005 06:55:27 +0200
User-agent: Mozilla Thunderbird 1.0.7 (X11/20050923)

Nicola Pero wrote:
>>So if I run configure with --prefix=/tmp, everything should end up under
>>/tmp, right?
> Yes ... well, no --, in some cases you're right and it wouldn't happen --
> you found a bug! :-)


> ... inherited environment variables were taking precedence over --prefix
> ... which is wrong ... I fixed it on CVS :-)
> Please try again :-)

Just updated from CVS and "configure --prefix=/tmp" does the right thing.

The csh vs. sh env bug remains, though :-(

Forgot to post the contents of my GNUstep.conf yesterday so here it goes:

---------------------------- schnipp ----------------------------------
## This is the GNUstep configuration file.

## Any line starting with a '#' is a comment.
## Empty lines are ignored.
## Every other line in this file must be of the form
##   XXX=YYY
## where there should be no spaces around the '=' (this is because we
## include this file in shell scripts and makefiles, and sh syntax
## requires no spaces around the '=').


---------------------------- schnapp ----------------------------------

This reminds me: my .GNUstepDefaults is located in ~/GNUstep/Defaults.
This used to be the default place and this is where the
GNUSTEP_USER_DEFAULTS_DIR env var points to. When the env var is missing
the .GNUstepDefaults file is created directly in my home dir ...

Was there a change in the defaults policy that I did miss?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]