[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Little Installation Problem.

From: Daniel J Farrell
Subject: Little Installation Problem.
Date: Mon, 16 Jan 2006 17:13:35 +0000

Hello everyone,

A few days ago I was asking for advice on how to install the base framework on Ubuntu so I could make my own apps using the gnustep framework. Well I have started again, deleted eveything, because I would like to use project center as my IDE. I'm having a little problem with this fresh install.

I have downloaded the these files from ftp://ftp.gnustep.org/pub/ daily-snapshots/ :

And have been following the very clear installation instructions in the gnustep site (www.gnustep.org/resources/documentaion/User/GNUstep/ gnustep-howto_3.html). I also checked that I have all the prerequisites.

I unpacked the files and changed directory to gnustep-make then:

sudo ./configure --prefix=/usr/local/GNUstep

*/The part that of the output relates to the PATH variables is here:
checking for GNUSTEP_SYSTEM_ROOT to use... /usr/local/GNUstep/System
checking for GNUSTEP_LOCAL_ROOT to use... /usr/local/GNUstep/Local
checking for GNUSTEP_NETWORK_ROOT to use... /usr/local/GNUstep/Network

sudo make
sudo make install

My GNUstep.sh is located in a different location so I run (is this significant?):
. /usr/local/GNUstep/System/Makefiles/GNUstep.sh

I then change to run the base package and after sudo ./configure it appears to be okay the I run sudo make and it all falls apart. The main error seems to be about the PATH variables.

/usr/local/GNUstep/System/Makefiles/common.make:137: WARNING: Your PATH may not be set up correctly ! /usr/local/GNUstep/System/Makefiles/common.make:138: Please try again after running ". /usr/local/GNUstep/System/Makefiles/GNUstep.sh"

The rest of the output errors are here:
make[3]: *** [shared_obj/ix86/linux-gnu/gnu-gnu-gnu/GSMime.o] Error 1
make[2]: *** [Additions.all.subproject.variables] Error 2
make[2]: Leaving directory `/home/daniel/Desktop/gnustep- base-1.4.0pre1/Source/Additions'
make[1]: *** [libgnustep-base.all.library.subprojects] Error 2
make[1]: Leaving directory `/home/daniel/Desktop/gnustep- base-1.4.0pre1/Source'
make: *** [internal-all] Error 2

Hopefully, there is a silly mistake somewhere!


reply via email to

[Prev in Thread] Current Thread [Next in Thread]