[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: gnustep-base library versioning

From: Adam Fedor
Subject: Re: gnustep-base library versioning
Date: Wed, 3 Jan 2007 11:20:22 -0700

On Jan 3, 2007, at 10:15 AM, Larry Campbell wrote:

Yes, but if one component wants to use a new version and nineteen others don't care, the nineteen others still have to relink if they're to be deployed along with the one. It's the relinking of the nineteen others that's the killer.

You should be able to install several versions of the GNUstep libraries at once, unless you are installing from a distribution that does not allow that. Applications should use the old version unless they are specifically recompiled. It's possible this could be a problem since Resources aren't versioned, but it's not likely.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]