discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: gnustep-make-2.0.0 regression


From: Yen-Ju Chen
Subject: Re: gnustep-make-2.0.0 regression
Date: Sun, 22 Apr 2007 22:38:59 -0700

On 4/22/07, Dirk Meyer <address@hidden> wrote:

I tried to build all gnutep stuff with gnustep-make-2.0.0

The installation of most applications broke.

I expected some Problems with GNUSTEP_INSTALL* Macros,
but the Problem is a diffrent one.

The Application are now installed under Tools/
and the necessary ressouces are not installed.

Small examples are GShisen and Gomoku,
The GNUMakefile hast nothing special.

I tried Gomoku and have no problem (see log below):
It installs Gomoku.app in Local/Applications and Gomoku in Local/Tools.
I can either use 'openapp Gomoku' or straight 'Gomoku' to launch it.
I use Linux and use GNUstep layout, though.

Yen-Ju

address@hidden:~/Desktop/Gomoku-1.2.8$ make
This is gnustep-make 2.0.0. Type 'make print-gnustep-make-help' for help.
Making all for app Gomoku...
Creating Gomoku.app/....
Compiling file Board.m ...
Compiling file Controller.m ...
Compiling file main.m ...
Linking app Gomoku ...
Creating Gomoku.app/Resources...
Creating Gomoku.app/Resources/Info-gnustep.plist...
Creating Gomoku.app/Resources/Gomoku.desktop...
Copying resources into the app wrapper...
Copying localized resources into the app wrapper...

address@hidden:~/Desktop/Gomoku-1.2.8$ sudo make install messages=yes
This is gnustep-make 2.0.0. Type 'make print-gnustep-make-help' for help.
/usr/local/GNUstep/System/Library/Makefiles/common.make:720: WARNING:
Your PATH may not be set up correctly !
/usr/local/GNUstep/System/Library/Makefiles/common.make:721: Please
try again after adding "/usr/local/GNUstep/System/Tools" to your path
Making all for app Gomoku...
for f in Empty.png EmptyLeft.png EmptyRight.png EmptyTop.png
EmptyBottom.png EmptyTopLeft.png EmptyTopRight.png EmptyBottomLeft.png
EmptyBottomRight.png Computer.png ComputerLeft.png ComputerRight.png
ComputerTop.png ComputerBottom.png ComputerTopLeft.png
ComputerTopRight.png ComputerBottomLeft.png ComputerBottomRight.png
Human.png HumanLeft.png HumanRight.png HumanTop.png HumanBottom.png
HumanTopLeft.png HumanTopRight.png HumanBottomLeft.png
HumanBottomRight.png Gomoku.png; do \
         if [ -f $f -o -d $f ]; then \
           cp -fr $f ./Gomoku.app/Resources/; \
         else \
           echo "Warning: $f not found - ignoring"; \
         fi; \
       done
for l in English Italian French Swedish Spanish German
TraditionalChinese Hungarian Norwegian; do \
         if [ -d $l.lproj ]; then \
           /usr/local/GNUstep/System/Library/Makefiles/mkinstalldirs
./Gomoku.app/Resources/$l.lproj; \
           for f in Localizable.strings; do \
             if [ -f $l.lproj/$f -o -d $l.lproj/$f ]; then \
               cp -fr $l.lproj/$f \
                     ./Gomoku.app/Resources/$l.lproj/; \
             else \
               echo "Warning: $l.lproj/$f not found - ignoring"; \
             fi; \
           done; \
         else \
           echo "Warning: $l.lproj not found - ignoring"; \
         fi; \
       done
Making install for app Gomoku...
rm -rf /usr/local/GNUstep/Local/Applications/Gomoku.app; \
       (cd ./.; \
           tar chfX -
/usr/local/GNUstep/System/Library/Makefiles/tar-exclude-list
Gomoku.app) \
        | (cd /usr/local/GNUstep/Local/Applications; tar xf -)
\
         cd /usr/local/GNUstep/Local/Tools/.; \
         rm -f Gomoku; \
         ln -s
`/usr/local/GNUstep/System/Library/Makefiles/relative_path.sh
/usr/local/GNUstep/Local/Tools/.
/usr/local/GNUstep/Local/Applications/Gomoku.app/./Gomoku` \
                 Gomoku



kind regards Dirk

- Dirk Meyer, Im Grund 4, 34317 Habichtswald, Germany
- address@hidden,address@hidden,address@hidden
http://people.freebsd.org/~dinoex/errorlogs/


_______________________________________________
Discuss-gnustep mailing list
address@hidden
http://lists.gnu.org/mailman/listinfo/discuss-gnustep





reply via email to

[Prev in Thread] Current Thread [Next in Thread]