discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: font substitution


From: Yen-Ju Chen
Subject: Re: font substitution
Date: Sun, 12 Aug 2007 16:48:50 -0700

On 8/12/07, Fred Kiefer <address@hidden> wrote:
> Yen-Ju Chen wrote:
> > On 8/12/07, Fred Kiefer <address@hidden> wrote:
> >> Yen-Ju Chen wrote:
> >>> On 8/12/07, Yen-Ju Chen <address@hidden> wrote:
> >>>> On 8/12/07, Fred Kiefer <address@hidden> wrote:
> >>>>> I tried both the AR PL fonts and they seem to work for me. The problem
> >>>>> you reported in the other mail was when creating the character set, not
> >>>>> when checking if a character was included. Perhaps you could send me
> >>>>> your test file. At the moment I am not able to reproduce the problem.
> >>>>>
> >>>>> Excluding some fonts from the check wont be an option as people may want
> >>>>> to use this fonts anyway and then we have the same problem. We really
> >>>>> need to find out, what is going wrong here.
> >>>>>
> >>>>> And GNUstep should be able to support all Unicode characters, if not we
> >>>>> need to change this. From looking at the code I see no limitation.
> >>>>   Here is the text I used. It is in UTF-8 encoding.
> >>>>   You need a Chinese font (AR PL...)
> >>>>   and another font which has better coverage than usual,
> >>>>   probably one of the DejaVu font for a row of symbol in the bottom.
> >>>   I check the fonts again.
> >>>   The one in question is "AR PL ZenKai Uni.nfont".
> >>>   It shows a "Critical Error" of NSCharacterSet panel and
> >>>   and an exception in terminal:
> >>>   " NSImage: compositeToPoint:fromRect:operation: failed due to
> >>>     NSInternalInconsistencyException: Cannot find stored representation"
> >>>
> >>>   If you want to try, there is an application in Etoile:
> >>>   Etoile/Services/User/Typewriter/
> >>>   (Well, you also need Etoile/Frameworks/OgreKit, which need oniguruma 
> >>> library).
> >>>   You can create a new document, choose "Edit"->"Characters...".
> >>>   It is a panel allowing you to see all of the glyphs from a chosen font.
> >>>   When you choose "ZenKai", the exception raises.
> >>>   Or you can use Etoile/Services/User/FontManager/ (no dependency).
> >>>   It has the same result.
> >>>   I have to say a bad font can be anywhere.
> >>>
> >> Thank you for all these advices. I was able to reproduce and understand
> >> the flipping of the font. It happens when a font without an explicit set
> >> matrix gets replaced by an explicit matrix. This is rather strange and
> >> most likely wrong. To work around this problem I now use a font manager
> >> method, which in the end does exactly what you suggested. This way has
> >> the benefit that when ever we improve the code in NSFontManager the font
> >> substitution will also improve.
> >
> >   That sounds great !!
> >
> >> Even with all your help I was not able to reproduce the NSCharacterSet
> >> problem. Is it possible that this only happens with a certain version of
> >> Freetype? I seem to have libfreetype.so.6.3.16 on my SuSE 10.2 system.
> >
> >   Hmm... It is possible. I use Ubuntu 6.10/PPC.
> >   I have to check what version of freetype on the system.
> >   But what surprises me is that NSFont can get the correct numberOfGlyphs.
> >   So it may be something unrelated to NSFont, but glyph rendering.
> >
> >   By the way, could you add a user default for -gui or -back,
> >   such as NSPreferredFonts,
> >   so that users can easily specify their preferred fonts ?
>
> Oops, I thought I did that already. It should be NSPreferredFonts, but I
> never tried it myself :-(
>

  O.K. NSPreferredFonts in user defaults works.
  My freetype is 6.3.10.
  Well, before Ubuntu update freetype2,
  I have to temporarily remove the bad font.

  Yen-Ju




reply via email to

[Prev in Thread] Current Thread [Next in Thread]