discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Sudden death of all GNUstep apps.


From: J. Jordan
Subject: Re: Sudden death of all GNUstep apps.
Date: Sun, 23 May 2010 22:23:05 +0200
User-agent: GNUMail (Version 1.2.0)

Thanks all, but I rolled back to Startup0.23.0, perhaps I will give give 0.25.0 another try in a few weeks, right now an operational system is more important to me. Your idea about gdnc may well be correct because the version from 0.23.0 was running when I installed 0.25.0, perhaps the file was locked but I did not notice any errors. Perhaps next time I will do the install without Xwindows running, actually gdnc is started even before that so I guess I will have to disable it in my init.d scripts.

I am running on Linux/X-windows, sorry for not mentioning that; I still have a hard time fathoming anyone running GNUstep on the Microsoft Virus Distribution System.

Thanks again,

-j

On 2010-05-23 20:26:39 +0200 Fred Kiefer <address@hidden> wrote:

David may well be right with his diagnosis. If he is, just ignore my mail.

 From the back trace you send I would say that your distributed
notification centre doesn't match the signatures of the calling
application. Most likely due to the fact that you are using an outdated
version of gdnc. Could you please search your computer for that
executable and check all found instances whether they are from the
latest GNUstep release you installed?
You should also try to find out, from where gdnc gets started and
whether this is the correct path.

For more diagnostic you will have to provide more information. What
system are you running GNUstep on? What did you change prior to the last
reboot? Are all your GNUstep components coming from the startup 0.25.0
release?
 From your previous mails I can deduct that you installed libffi 3.0.9
after installing GNUstep. Did you recompile all of GNUstep after this
step? If not, please do so.

Hope this helps
Fred

Am 23.05.2010 15:57, schrieb james Jordan:
On the last reboot of my system all GNUstep apps suddenly will not work. I
am getting dialog boxes when I try to open that say things like:

Terminal:
NSInvalidArgumentExceptoion: NSConection types (address@hidden:address@hidden@address@hidden /
address@hidden:address@hidden@address@hidden@56) missmatch for
addObserver:selector:name:object:suspensionBehavior:for:

Backtrace:
Program received signal SIGABRT, Aborted.
0x00007ffff62d04b5 in raise () from /lib/libc.so.6
(gdb) backtrace
#0  0x00007ffff62d04b5 in raise () from /lib/libc.so.6
#1  0x00007ffff62d3f50 in abort () from /lib/libc.so.6
#2  0x00007ffff6ec36de in _terminate () at NSException.m:695
#3  0x00007ffff6ec397b in _NSFoundationUncaughtExceptionHandler (
     exception=0xbf0830) at NSException.m:722
#4  0x00007ffff6ec39ae in callUncaughtHandler (value=0xbf0830)
     at NSException.m:734
#5  0x00007ffff6ec4174 in -[NSException raise] (self=0xbf0830,
     _cmd=0x7ffff7a93440) at NSException.m:871
#6  0x00007ffff75d85f2 in _NSAppKitUncaughtExceptionHandler (
     exception=0xbf0830) at NSApplication.m:146
#7  0x00007ffff6ec39ae in callUncaughtHandler (value=0xbf0830)
     at NSException.m:734
#8  0x00007ffff6ec4174 in -[NSException raise] (self=0xbf0830,
     _cmd=0x7ffff7b88630) at NSException.m:871
#9  0x00007ffff7784a44 in -[_GSWorkspaceCenter init] (self=0xa6eec0,
     _cmd=0x7ffff7391ef0) at NSWorkspace.m:299
#10 0x00007ffff6f0a979 in +[NSObject new] (self=0x7ffff7b882e0,
     _cmd=0x7ffff7b884e0) at NSObject.m:1110
#11 0x00007ffff778575f in -[NSWorkspace init] (self=0x7f9410,
     _cmd=0x7ffff7b885b0) at NSWorkspace.m:642
#12 0x00007ffff77855af in +[NSWorkspace sharedWorkspace]
(self=0x7ffff7b88100,
     _cmd=0x7ffff7a93c40) at NSWorkspace.m:611


I get similar results with \:
GNUMail
batmon
AClock
etc., etc.

All of which worked before I rebooted.


GWorkspace does not give a dialog and has a different backtrace:
(gdb) backtrace
#0 0x00007ffff64afa55 in objc_msg_lookup () from /usr/lib/libobjc.so.2
#1  0x00007ffff6a7c8a5 in NSCreateMapTableWithZone (k=..., v=...,
capacity=0,
     zone=0x7ffff6f03a40) at NSConcreteMapTable.m:441
#2 0x00007ffff5a7a309 in +[NSObject initialize] (self=0x7ffff5e2e9c0,
     _cmd=<value optimized out>) at NSObject.m:1038
#3  0x00007ffff64af7ca in ?? () from /usr/lib/libobjc.so.2
#4 0x00007ffff64afbb8 in objc_msg_lookup () from /usr/lib/libobjc.so.2
#5  0x0000000000408be2 in main (argc=<value optimized out>,
argv=<value optimized out>, env=<value optimized out>) at main.m:32

I tried reinstalling startup 0.25.0 again but it did not seem to make any
difference.

Any ideas would be greatly appreciated, I am pretty much dead in the water
here, using webmail to write this and xterm to troubleshoot.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]