discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: applications that fail to build with new gnustep from svn


From: Sebastian Reitenbach
Subject: Re: applications that fail to build with new gnustep from svn
Date: Fri, 8 Apr 2011 11:12:56 +0200
User-agent: KMail/1.13.5 (Linux/2.6.34.7-0.7-xen; KDE/4.4.4; x86_64; ; )

On Friday, April 08, 2011 11:05:26 am Nicola Pero wrote:
> >>> * with price and graphos, I haven't yet tested the latest svn checkout,
> >>> Riccardo, do you tested to compile those two?
> >> 
> >> -> I compiled both Graphos and PRICE from CVS and they built fine on
> >> Linux+gcc
> > 
> > If that code works for you, you really should update your compiler :-)
> > There is a horrible bug in the code. When you changed the code from using
> > floats into using real NSColor objects you forgot to clean up the method
> > psDescription, it still expects floats where there are objects now. A
> > good compiler may be able to warn about this misuse.
> 
> By the way, if GCC 4.6 doesn't warn about horribly broken Objective-C code,
> you should file a bug report with GCC --
When I use gcc, then I use 4.2.1 from the base system, the latest gcc in the 
ports tree is 4.3 something.

Sebastian

> 
> http://gcc.gnu.org/bugzilla/
> 
> :-)
> 
> Thanks
> _______________________________________________
> Discuss-gnustep mailing list
> address@hidden
> http://lists.gnu.org/mailman/listinfo/discuss-gnustep



reply via email to

[Prev in Thread] Current Thread [Next in Thread]