discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Loading xibs


From: Fred Kiefer
Subject: Re: Loading xibs
Date: Thu, 12 May 2011 09:01:01 +0200
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; de; rv:1.9.2.17) Gecko/20110414 SUSE/3.1.10 Thunderbird/3.1.10

Thank you for this stripped down example code. I had to change just one call to a property into a method call and then it compiled perfectly for me (OK, there are two missing methods warnings, that you should look into, but nothing serious) Next I tried to run the code and it just worked, loaded up a menu and some sort of file dialogue. It complained about connections it could not establish:

2011-05-12 08:48:09.186 Zcode[5135] Error while establishing connection <IBOutletConnection: 0x11641e0>: data source does not respond to outlineView:isItemExpandable: 2011-05-12 08:48:09.220 Zcode[5135] Error while establishing connection <IBOutletConnection: 0x11645a0>: Data Source doesn't respond to numberOfRowsInTableView:

This is due to your stub definition of the class ProjectDetailListDataSource. I also had a look into your XIB file and it is the older format, this means even before the recent change to XIB loading it should have been possible to load this file.

As it works for me, but fails for you you will have to do what you should have done right from the start: Send me the back trace of the error you are getting. Most likely you are one a more fragile architecture and we have some sloppy code in there that only fails on certain machines. Could you please run the application in gdb and report back the back trace you get? My favourite way of doing this is openapp --debug, but I am rather old fashioned.

Cheers
Fred

PS: As for the gcc version hard coding in GNUmakefile.preamble, this is a ProjectCenter bug and it should best be reported in our bug tracker to get the attention of the ProjectCenter maintainers.

On 11.05.2011 22:54, Ivan Vučica wrote:
in case you don't have time to grab GCC 4.6, I've attempted to filter out
code that uses properties, and I have attempted to leave minimum code I
could to get the program to crash with .xibs.

Since I have to hurry, I didn't test this small example with either .gorm
files (with which Zcode works), nor on OS X (where .xibs were successfully
compiled into .nibs and the program ran well with them).

http://dl.dropbox.com/u/8559454/zcode-xib-crash.tar.gz

By the way, what's the policy on attaching "smallish" attachments on this
mailing list? (This .tar.gz is about 22 kB in size.)

It is interesting that the program doesn't hard-crash if you remove
ProjectDetailListDataSource class. .xib fails to load completely, since the
class is undefined, but the window is displayed and the splitview is handled
ok.

2011/5/11 Fred Kiefer<address@hidden>

As I expected, I cannot compile your code as it uses properties and my gcc
4.5.1 doesn't support them.

What I could detect is that one of your XIB files was produced by a rather
new version of XCode and has the XIB version 8.00. This version seems to
have added the two element types "array" and "dictionary" as short cuts for
these two classes. I added support of these into our GSXibLoader. Not sure
whether that was your problem and if this is solved now. But if the loading
of NIB files already fails, then I expect that your problem is on a
different level.

As you didn't share any information about that, I will have to wait for a
version of gcc that supports properties and try again at that time.

Fred



On 02.05.2011 20:32, Ivan Vučica wrote:

NHF = No hard feelings

Okay then. I hope Zcode's xibs can help out a bit with testing whether
things work.

On 2. svi. 2011., at 20:23, Gregory Casamento wrote:

  Xib loading is still in the experimental stage, I'm still working on
it.   Also 3.0 nibs lack certain things which 2.0 nibs had... so there
is still some work to do on both fronts.

Also NHF? I'm not sure what that means.

GC

2011/5/2 Ivan Vučica<address@hidden>:

Hi!

Yesterday, after being slightly frustrated by Gorm (NHF Greg :)) in
Zcode I attempted to load xibs instead of gorm files. I also attempted to
use nibs from the compiled build of the app from OS X.

Neither worked.

Is someone more intimate with xib loading code willing to take a look at
the issues? The source code is available in a Mercurial repository, all that
you would need to change is GNUmakefile. You'd have to replace references to
.gorm files with references to .xib files:

hg clone https://bitbucket.org/ivucica/zcode/ zcode

A few notes about Zcode:
- Compiling is done in a standard way: ./configure, make.
- Project makes heavy use of Objective-C 2.0 and is most recently tested
with GCC 4.6 on Debian
- I'm making use of NSViewControllers, I have several top level objects,
I have an outline view with images, I have tons of autoresizing, ...

GNUstep libraries that i used: svn r32902



reply via email to

[Prev in Thread] Current Thread [Next in Thread]