[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Building GWorkspace, and GNUstep.sh

From: Austin Clow
Subject: Building GWorkspace, and GNUstep.sh
Date: Sat, 28 May 2011 22:11:26 -0500

Hello all!

I am hoping someone can help me with a few things that I am clearly doing 
wrong, with building GWorkspace.  

Yesterday, I decided to build a GNUstep system in a fresh install of Ubuntu 
--not using the Ubuntu Software Center (except for dependencies). I built the 


I installed all the dependencies, and built all the previous; it worked fine. 
Then I installed ProjectCenter. Worked perfectly. Opened it up, and compiled a 
new project. Project ran fine. Then I tried to build gworkspace-0.8.8; Fail.

I cd'd to the gworksapce-0.8.8 folder and tried

I got the error:  You must run the gnustep initialization script first

So I looked online and found that I needed to run the GNUstep.sh script (in the 
Makefiles directory)

I ran into some problems. I could *not* run the script as sudo as it tells me 
that the script didn't exist. (I am sure I am doing this wrong)
        sudo ./GNUstep.sh

But I could run it normally. 
      . /usr/…/Makefiles/GNUstep.sh

So then I preceded to try
      ./configure on gworksapce-0.8.8


Then, make, worked

Then, make-install, it starts doing its thing but fails with:
      make[2]: *** [internal-framework-install_] Error 2
      make[1]: *** [FSNode.install.framework.variables] Error 2
      make: *** [internal-install] Error 2

If I try at this point to do it as sudo make, it tells me this:
      GNUmakefile:5 /common.make: No such file or directory
      GNUmakefile:33: /aggegate.make: No such file or directory
      make: *** NO rule to make target '/aggregate.make" stop

It gives a lot of other "permission denied" errors (probably because I can't 
run it in sudo!) I have only just started doing GNUstep things in the past 
week, so I know there is a lot to learn. But I have a feeling that it has to do 
with the fact that I can't run ./GNUstep.sh with sudo. So I can't run sudo make 
on gworksapce-0.8.8. Or something.  

reply via email to

[Prev in Thread] Current Thread [Next in Thread]