[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Building GWorkspace, and GNUstep.sh

From: Riccardo Mottola
Subject: Re: Building GWorkspace, and GNUstep.sh
Date: Mon, 30 May 2011 09:00:00 +0200
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20110516 Icedove/3.1.10

I got the error:  You must run the gnustep initialization script first

So I looked online and found that I needed to run the GNUstep.sh script (in the 
Makefiles directory)

I ran into some problems. I could *not* run the script as sudo as it tells me 
that the script didn't exist. (I am sure I am doing this wrong)
        sudo ./GNUstep.sh

But I could run it normally.
       . /usr/…/Makefiles/GNUstep.sh

So then I preceded to try
       ./configure on gworksapce-0.8.8


Then, make, worked

Then, make-install, it starts doing its thing but fails with:
       make[2]: *** [internal-framework-install_] Error 2
       make[1]: *** [FSNode.install.framework.variables] Error 2
       make: *** [internal-install] Error 2

If I try at this point to do it as sudo make, it tells me this:
       GNUmakefile:5 /common.make: No such file or directory
       GNUmakefile:33: /aggegate.make: No such file or directory
       make: *** NO rule to make target '/aggregate.make" stop

It gives a lot of other "permission denied" errors (probably because I can't 
run it in sudo!) I have only just started doing GNUstep things in the past week, so I 
know there is a lot to learn. But I have a feeling that it has to do with the fact that I 
can't run ./GNUstep.sh with sudo. So I can't run sudo make on gworksapce-0.8.8. Or 

Well, the problem is that "sudo" often resets some of your environment variables.

To compile and run stuff, you need to have sourced GNUstep.sh as the running user, the user you are logged in as. Sourcing that file essentially sets a bunch of environment variables. One important thing is that it adds places to your linker path so that it finds the various libraries present in the frameworks. Sudo however tends to resets them (there are some defaults to play with).

Usually this works:

$. /xxx/GNUstep.sh
$sudo make install

There are some tricky packages which do some stuff during installation, for those you need to:
#. /xxx/GNUstep.sh
#make install

A third option is that you make the GNUstep directory writable to your user by adding yourself to a certain group and giving group permissions. This is a comfortable approach on a development machine you use yourself (and have no other people in that group) or inside VMs which you know you use only yourself. That way you can install applications as a standard user.

I hope this quick explanation was enough to get you some understanding.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]