discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Please test pending bugfix release of base


From: Sebastian Reitenbach
Subject: Re: Please test pending bugfix release of base
Date: Sat, 18 Jun 2011 14:08:33 +0200
User-agent: SOGoMail 1.3.7

Hi again,

On Saturday, June 18, 2011 09:41 CEST, Richard Frith-Macdonald <address@hidden> 
wrote:

>
> On 17 Jun 2011, at 11:39, Quentin Mathé wrote:
>
> > Hi Richard,
> > > Le 16 juin 2011 à 09:58, Richard Frith-Macdonald a écrit :
> > >> It's long enough now since the last release that I'd like to make a 
> > >> bugfix release of the base library (going from 1.22.0 to 1.22.1).
> >> This release is mostly for portability issues, but there are fixes to 
> >> atomic operations used for retain/release safety, which would be important 
> >> to threaded software, so we really should make a release for tis alone.
> >> The idea is not to add any new features, just to make things even more 
> >> reliable and portable.
> >> >> Please could people (especially those with unusual hardware and/or 
> >> >> obscure/old operating systems) give this a try so we can make this 
> >> >> release as portable and reliable as possible.
> >> >> You can get hold of the pre-release code using subversion from 
> >> >> svn://svn.gna.org/svn/gnustep/libs/base/branches/stable
> >> If there is anyone who really can't use subversion but would like to try 
> >> this, please let me know and I'll send you a .tar.gz archive of the source 
> >> (approx 3MB email).

another patch attached. In the GNUmakefile for the SSL bundle, I found a 
-lobjc, so that it is always linked against a libobjc.so.
The problem I now have with this is the following:
I installed libobjc1 for sparc as /usr/local/lib/libgobjc1.so.0.0 and told 
gnustep-make to use this libobjc when linking using the following parameter: 
--with-objc-lib-flag=-lgobjc1
In the end result, all but the SSL bundle was linked against libgobjc1, and the 
SSL bundle was linked againt libobjc.

Attached patch just removes -lobjc. Without it, it just links against libgobjc1:

$ ldd 
/usr/local/lib/GNUstep/Libraries/gnustep-base/Versions/4.0/Resources/SSL.bundle/SSL
/usr/local/lib/GNUstep/Libraries/gnustep-base/Versions/4.0/Resources/SSL.bundle/SSL:
        Start    End      Type Open Ref GrpRef Name
        000a9000 200ad000 dlib 1    0   0      
/usr/local/lib/GNUstep/Libraries/gnustep-base/Versions/4.0/Resources/SSL.bundle/SSL
        003f7000 20403000 rlib 0    1   0      /usr/lib/libssl.so.16.0

        000ad000 200ea000 rlib 0    1   0      /usr/lib/libcrypto.so.19.0
        013f8000 2156e000 rlib 0    1   0      
/usr/local/lib/libgnustep-base.so.4.0
        016bb000 216c1000 rlib 0    2   0      /usr/local/lib/libgobjc1.so.0.0
...

Sebastian

Attachment: patch-SSL_GNUmakefile
Description: Binary data


reply via email to

[Prev in Thread] Current Thread [Next in Thread]