discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: OsiriX [Was: environment]


From: Ivan Vučica
Subject: Re: OsiriX [Was: environment]
Date: Sun, 14 Aug 2011 12:39:12 +0200

Looks like libkern is OS X specific library.

You may want to request an updated GNUstep port from OsiriX developers.

On Sun, Aug 14, 2011 at 12:05, Philip G Batchelor <address@hidden> wrote:
Hi

Thanks a lot, I justc ompiled, and indeed, pbxbuild worked. Trying Osirix , but I guess the signs are not so good then. Just feels such a popular tool, with a name ending in *ix should be possible!

(For the moment, Osirix compilation fails at  'libkern/OSByteOrder.h: No such file or directory' but that was a first attempt,
I'll try more).

Cheers
Ph



On 13/08/11 19:02, Fred Kiefer wrote:
The error message you where getting in the first place was a bug in
pbxbuild, which required that all targets, even non-apps, had an
INFOPLIST_FILE entry in their configuration. This and a few other minor
bugs should be fixed now. Please update from SVN.

 From the last time somebody tried to compile OsiriX I remember that
this wasn't working with GNUstep. I tried to get it working myself at
the time and found that this wasn't possible even after fixing the
trivial problems I had first. OsiriX seems to rely on plenty of
libraries that aren't around in a standard Linix system and some of the
code isn't written in a portable way. I am willing to help you get as
far as I did at that time, but please don't expect too much.

Cheers
Fred

On 12.08.2011 20:19, Philip G Batchelor wrote:
I have a question, sorry in advance for my ignorance of the context.

I just installed GNUStep on my Ubuntu system, with the aim of trying to
compile Osirix. After lots of Google searches, I got the impression that
it wasn't done often, but someone might have been successful.

I first installed GNUStep from Ubuntu repositories, but I was still
missing a tool to generate Makefiles for Osirix as it is using xcode (a
concept I don't know well, I have never had OSX). From further googling,
I found remarks about a tool called pbxbuild, but it wasn't in the
Ubuntu repository as far as I can tell, thus I uninstalled and used the
svn GNUStep--which does contain it. But when I runt it on the
Osirix.xcodeproj, I get:

 >pbxbuild OsiriX.xcodeproj/
2011-08-12 19:13:04.619 pbxbuild[19549] Warning: Unknown reference type
'XCVersionGroup' in PBXGroup!
2011-08-12 19:13:04.933 pbxbuild[19549] File NSData.m: 161. In
readContentsOfFile Open ((null)) attempt failed - bad path

I guess something is wrong with a path? I did run GNUstep.sh
I also see mentions of zcode, what's the status compared to pbxbuild?

Thanks in advance

Ph

PS: more details:
I managed to compile GNUStep (make, base,gui,back) , and install as
recommended, and indeed, it seems the environment I get doesn't
correspond to what is described in ./core/make/GNUstep-HOWTO

I had installed with ./configure without prefix. After that failure I
retried ./configure --prefix=/usr/local

I did run the recommended script GNUStep.sh, and as this didn't help, I
was going to try to set environment variables manually, but for example
the HOWTO says to set:
'PATH="/usr/GNUstep/System/Tools:"

the problem is I can't find a System/Tools folder!?


Would anyone have a hint of something to try? I'm thinking I need to
clean my environment from previous installation attempts somehow anyway,
but I might also have missed a compilation-install step.


_______________________________________________
Discuss-gnustep mailing list
address@hidden
https://lists.gnu.org/mailman/listinfo/discuss-gnustep



--
Ivan Vučica - address@hidden



reply via email to

[Prev in Thread] Current Thread [Next in Thread]