discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GNUstep on 10.7


From: artware
Subject: Re: GNUstep on 10.7
Date: Sat, 27 Aug 2011 16:43:26 -0500

Is there any way to determine which libffi is being chosen, so I can
remove it? Other than pkg-config, which won't build because it
required pkg-config?

Or is there a way to specify exactly which library to use?
--with-libffi-library does not seem to do anything.

Ben

On Sat, Aug 27, 2011 at 4:37 PM, artware <address@hidden> wrote:
> After spending all day yesterday trying to get this to work, I
> probably have a libffi in every other directory. I wiped out two, and
> I'm currently doing a find / -name libffi.dylib to find the rest.
>
> There are many libffi copies in the MacOSX sdks, but I can't get rid of those.
>
> libobjc2 from svn is the one I'm trying to compile—I'm following
> David's instructions as closely as possible.
>
>
> On Sat, Aug 27, 2011 at 4:22 PM, Adam Fedor <address@hidden> wrote:
>> Well, if you removed it and it still worked, that probably  means there was 
>> another libffi somewhere.
>>
>> And if you are using clang, you probably want libobjc2, not libobjc. You 
>> should look at the instructions that David sent a link to.
>>
>> To install. Make sure you source the GNUstep.sh script
>>
>> . /System/Library/Makefiles/GNUstep.sh
>>
>> (make sure the patch is correct for where you install GNUstep).  If that 
>> still doesn't work, it's because sudo does not pass on environment 
>> variables, and you'd have to do something like
>>
>> sudo make GNUSTEP_MAKEFILES=/System/Library/Makefiles install
>>
>



reply via email to

[Prev in Thread] Current Thread [Next in Thread]