[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Duplicity-talk] restore a single Directory

From: edgar . soldin
Subject: Re: [Duplicity-talk] restore a single Directory
Date: Sat, 05 Sep 2009 12:10:06 +0200
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/20090715 Thunderbird/3.0b3

As you try to restore a folder I would suggest leaving the trailing slash ... try
ftplicity mordac fetch var/www/WebSite/web/Films /root/backupWebSite 30D

I doublechecked and obviously duplicity uses the path name that you can also see with the list command. Without a trailing slash I didn't get the 'not found' error.

also .. what does 'duplicity version' output? .. there seems to be an error. Seems not to be critical but, could you please send it, so I can improve ftplicity...

.. ede

On 04.09.2009 23:56, Andre Dieball wrote:
Hi Ede

basically, this is what I tried ....

I did:
ftplicity mordac fetch var/www/Website/web/Films/ /root/backupWebsite/ 30D --preview

which returns the following duplicity command:
/usr/bin/duplicity --verbosity 4 --encrypt-key 12345678 --sign-key 12345678 --gpg-options="" --restore-time 30D --file-to-restore var/www/WebSite/web/Films/ ftp://address@hidden/mordac/ /root/backupWebSite/

But runnign this via ftplicity returns the following:

address@hidden web]# ftplicity mordac fetch var/www/WebSite/web/Films/ /root/backupWebSite/ 30D
Start ftplicity v1.4.2.1, time is 09/04/09 23:47:55.
Using profile '/etc/ftplicity/mordac'.
Using installed Attention: Could not interpret your duplicity version string ((most




0.5.06)., gpg 1.4.5 (Home: ~/.gnupg)
Test - Encryption with key 12345678 (OK)
Test - Decryption with key 12345678 (OK)
Test - Compare Original w/ Decryption (OK)
Cleanup - Delete '/tmp/ftplicity.18003.1252100875_*'(OK)

--- Start running command FETCH (23:50:40.485) ---
Running duplicity - FAILED (code 30)
Output: NcFTP version is 3.2.2
Last full backup date: Tue Sep  1 03:00:02 2009
/var/www/WebSite/web/Films/ not found in archive, no files restored.
Traceback (most recent call last):
  File "/usr/bin/duplicity", line 583, in ?
  File "/usr/bin/duplicity", line 577, in with_tempdir
  File "/usr/bin/duplicity", line 540, in main
  File "/usr/bin/duplicity", line 304, in restore
File "/usr/lib64/python2.4/site-packages/duplicity/log.py", line 164, in FatalError
SystemExit: 19
--- Finished (23:51:00.698) - Runtime 00:00:20.213 ---

But that directory does exist:

address@hidden web]# ftplicity mordac list | grep Films
Thu Aug 27 13:34:39 2009 var/www/clients/client4/web3/web/Films
Wed Jul 1 19:04:07 2009 var/www/clients/client4/web3/web/Films/Kind560x320.flv Tue Jul 21 10:16:24 2009 var/www/clients/client4/web3/web/Films/Kindergarten560x320.flv
address@hidden web]#

That is waht is confusing me :-)

BTW: I also tried without the leading slah for the restore directory (as in the ftplicity manual) without any success

Thanks a lot in advance


Am 30.08.2009 um 19:38 schrieb address@hidden:

Basically I'm using ftplicity

Then why aren't you using the corresponding ftplicity command? In recent versions this would be ...

ftplicity <profile> fetch /srcpath /trgpath [<age>]

... ede

reply via email to

[Prev in Thread] Current Thread [Next in Thread]