[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

image and display issues still

From: Ken Raeburn
Subject: image and display issues still
Date: Thu, 26 Oct 2000 06:31:27 -0400

I haven't had much time to track the changes in Emacs for a while, or
even keep up on the mail, I'm afraid, but updated my sources yesterday
and tried out the latest code.

I noticed three problems fairly quickly.  The first is a new one, I
think, the other two I believe I've reported to Gerd before, but I'll
include the details again in case they're different or the problems
were supposed to be fixed.

(1) If I start up Emacs with a frame with no minibuffer, and a
    two-line minibuffer-only frame, the updating of the minibuffer is
    unreliable.  I don't get "C-x -" or "Find file: /foo/bar/" prompts
    anywhere visible; I do get "Garbage collecting..." but I don't get
    the "done" message".

    Also, in this situation, some text in the main Emacs frame
    flickers, as if it's being redrawn a lot.  I mostly noticed it
    with the mode line.

(2) If I start up Emacs as a single frame, and fire up Gnus, and look
    at a news article with an image too big for the window displaying
    the article buffer, and that image at the end of the article as
    far as I can tell, I can't look at the bottom of the image.
    Hitting SPC in the Summary buffer doesn't cause anything to move,
    nor will it take me to the next article.

    Going into the article buffer, I can put the cursor right after
    the image (on the same line, a really tall text cursor) and hit
    ^L, and it'll show me the top part of the image.  If I move
    forward one position, it shows me only the empty end of the
    buffer, with the cursor at the upper left, normal size.  Another
    ^F and it says I'm at the end of the buffer.  Hitting ^L now moves
    me back to just after the image, on the same line as the image

    It gets even weirder.  As I sit here typing this message in a
    different Emacs process, the Emacs session I described above,
    which is now sitting idle, has the image slowly creeping upwards
    ... like it's scrolling the article buffer one line every fifteen
    seconds or so.  I don't remember that happening before.  And it's
    always when I'm not looking directly at it. :-) It stopped when
    the top of the image reached the top of the window.

    After some experimenting with other articles, it appears that if
    the window is tall enough to display the whole image (I haven't
    experimented with wide images), then I can also display just the
    bottom part of the image along with some of the text.

(3) If I have two normal frames displayed, moving the mouse cursor
    from one to the other doesn't cause the flashing text cursor to
    start without some additional input.  Moving the mouse back into
    the frame that last had the "active" cursor does cause that cursor
    to start flashing again right away.

Oh yes, and the -elc.tgz file hasn't been updated in a while.  But
"make bootstrap" fixes things just fine.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]