[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: gnus/message binary attachment problem?

From: Kenichi Handa
Subject: Re: gnus/message binary attachment problem?
Date: Thu, 16 Nov 2000 09:04:25 +0900 (JST)

Miles Bader <address@hidden> writes:
> I just tried to send a mail message with an image attachment (a .png file).
> I used the `mml-attach-file' command (`C-c C-a'), which seemed to work fine.

> But when I looked at my BCC copy of the message, while all the MIME
> attachment headers &c were there, the image data was *binary*, and
> morever seemed to have been corrupted somewhere in the transfer (as one
> might expect from sending pure binary text).  Shouldn't message have
> encoded the image somehow?

I tried this:

M-x message-mail RET, then input To: and Subject: fields, and
input the body text "Test of C-c C-a.".
Then, C-c C-a temp.png RET RET emacs screen shot RET C-c C-c.

What I received is as below.   It seems that binary image
data is correctly encoded by base64.

Ken'ichi HANDA

    Date: Thu, 16 Nov 2000 08:58:04 +0900 (JST)
    X-Authentication-Warning: mule.m17n.org: handa set sender to address@hidden 
using -f
    Sender: address@hidden
    To: address@hidden
    Subject: test
    From: Kenichi Handa <address@hidden>
    Content-Type: multipart/mixed; boundary="=-=-="
    Content-Length: 10509


    Test of C-c C-a.

    Content-Type: image/png
    Content-Disposition: attachment; filename=temp.png
    Content-Transfer-Encoding: base64
    Content-Description: emacs screen shot


reply via email to

[Prev in Thread] Current Thread [Next in Thread]