[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Confusing naming of fringe i C-code

From: Kim F. Storm
Subject: Re: Confusing naming of fringe i C-code
Date: 14 Nov 2001 02:06:46 +0100
User-agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.1

Richard Stallman <address@hidden> writes:

>     So far, I've come across several different names for the fringes:
>     `fringe' is primarily used on user visible symbols,
>     `bitmap' is used without explicit reference to the fringe, e.g. 
> bitmap_type, x_draw_bitmap, ...   
>     This isn't wrong, but it would be clearer to use fringe_bitmap_type,
>     x_draw_fringe_bitmap, etc.
> The name bitmap_type seems reasonable, but x_draw_bitmap should be
> renamed to x_draw_fringe_bitmap.

The elements in bitmap_type are symbolic identifiers for the fringe
bitmaps, so fringe_bitmap_type clearly identifies its purpose.
>     `bitmap area' is used in several comments, as well as in 
> BITMAP_AREA_FACE_ID (= fringe face)
> It would be good to rename that, too.
>     `flags area' seems to be the favourite term throughout the code, e.g.
> flags_areas_extra, ...
> Is "flags area" in fact a synonym for "fringe"?  If so, it would be good
> to rename these names too.

I think so - I haven't seen flags area used for anything else.

>     And then there are the mixed forms FRAME_FLAGS_BITMAP_WIDTH and 
> Those names refer to the size of the bitmaps that are drawn in the
> fringe, so they should be left unchanged.

IMO, they should be renamed to FRAME_FRINGE_BITMAP_WIDTH/HEIGHT etc.
(I think _FLAGS_ refers to "flags area")

> Would you like to do it?

Yes, I will do so.

Is there a CVS policy to lock those files (using cvs edit), or do I just
go ahead with the changes?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]