[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: address@hidden: Zone]

From: Jason Rumney
Subject: Re: address@hidden: Zone]
Date: 13 Jun 2002 21:52:41 +0100
User-agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.3.50

Jason Rumney <address@hidden> writes:

> zone-when-idle 180 does indeed give a delay of around 18 seconds.
> But zone-when-idle 20 gives a delay of 20 seconds, so it is not as
> simple as a multiple of 10 out. I get the same results on GNU/Linux,
> so it is probably a bug in zone rather than a low level timer bug
> specific to Windows.

In fact, what I saw was the somewhat surprising behaviour that after
running (zone-when-idle 20), (zone-when-idle 180) does not change the
idle period to 180 seconds, but leaves it as 20 seconds.  On both
platforms, calling zone-leave-me-alone before (zone-when-idle 180)
results in the expected behaviour.

> "Almer S. Tigelaar" <address@hidden> writes:

> > I noticed an error in the "zone" package, it seems that the argument to
> > "zone-when-idle" is not in seconds but in 1/10ths of a second.
> > Reproduction:
> > try "M-x zone-when-idle 180"
> > Sit back and don't touch anything, notice that it zones out after 18
> > seconds, not 180 as the documentation suggests.
> > Remarks:
> > The "run-with-idle-timer" function does not exhibit this malfunction which
> > suggests that the problem lies within the zone package itself.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]