[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Reading sexp problem: Invalid read syntax: "?"

From: Kim F. Storm
Subject: Re: Reading sexp problem: Invalid read syntax: "?"
Date: 24 Feb 2003 12:27:51 +0100
User-agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.3.50

Christoph Conrad <address@hidden> writes:

> Hi,
> i have a strange problem with my CVS Emacs sometimes. Cause i cannot
> reproduce it with "emacs -q --no-site-file" and i suspect that it is a
> configuration problem, not a problem specific to CVS Emacs, i am
> asking here.
> In CVS Gnus contrib/xml.el there ist the following statement in
> method `xml-parse-elem-type':
>       (list '? elem)
> eval-defun reveals
> edebug-read-sexp: Invalid read syntax: "?"
> Changing the line above to
>       (list '?  elem)
> - that is adding one extra space after the question mark - and the
> error is gone.

In CVS Emacs, the Lisp Parser has been modified to require a character
constant to be separated from a following symbol by whitespace.

In the above code, the character constant is a space, but consider
        (list '?melem)

Here, you would probably agree to write (list '?m elem) for clarity.
And so (list '?  elem) isn't any different, conceptually.

However, it does seem plausible (or proven) that existing code does
indeed use the "single space" syntax so maybe we need to relax the
parser so that it only checks the token following a NON-whitespace
character constant.

I've cc:ed to emacs-devel for comments.  So WDYT?

Kim F. Storm <address@hidden> http://www.cua.dk

reply via email to

[Prev in Thread] Current Thread [Next in Thread]