[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

address@hidden: tex-mode: too many _ (underscores) interpreted as subsc

From: Richard Stallman
Subject: address@hidden: tex-mode: too many _ (underscores) interpreted as subscripts]
Date: Sat, 02 Oct 2004 21:19:05 -0400

Would someone please investigate this bug report and DTRT?
Stefan made these changes, but he hasn't responded to
my mail about this, so I think it is time to look
for someone else.

------- Start of forwarded message -------
Date: Fri, 30 Jul 2004 15:21:23 +0200
From: Christian Schlauer <address@hidden>
X-Accept-Language: en-us, en
To: address@hidden
Subject: tex-mode: too many _  (underscores) interpreted as subscripts
Sender: address@hidden
X-Spam-Status: No, hits=0.4 required=5.0
X-Spam-Checker-Version: SpamAssassin 2.55 (

This bug report will be sent to the Free Software Foundation,
not to your local site managers!
Please write in English if possible, because the Emacs maintainers
usually do not have translators to read other languages for them.

Your bug report will be posted to the address@hidden mailing 

Please describe exactly what actions triggered the bug
and the precise symptoms of the bug:

The News file of CVS Emacs announces the following for TeX mode:

*** verbatim environments are now highlighted in courier by font-lock
and super/sub-scripts are made into super/sub-scripts.

At the moment, it considers too many underscores as subscript
commands. While it leaves \cite{blah99:_long_title} and
\verb+file_name+ alone, it displays the commands
\nolinkurl{file_name_with_underscore.txt} and
\url{file_name_with_underscore.txt} (both available with the hyperref
package, the last one also with url.sty) wrong, that is, the first
letter after an underscore in these commands is transformed into a

In GNU Emacs (i386-mingw-nt5.1.2600)
  of 2004-05-19 on BERATUNG4
configured using `configure --with-gcc (3.3) --cflags 
- -I../../jpeg-6b-1/include -I../../libpng-1.2.4-1/include 
- -I../../tiff-3.5.7/include -I../../xpm-nox-4.2.0/include 
- -I../../zlib-1.1.4-1/include'

Important settings:
   value of $LC_ALL: nil
   value of $LC_COLLATE: nil
   value of $LC_CTYPE: nil
   value of $LC_MESSAGES: nil
   value of $LC_MONETARY: nil
   value of $LC_NUMERIC: nil
   value of $LC_TIME: nil
   value of $LANG: DEU
   locale-coding-system: cp1252
   default-enable-multibyte-characters: t

Major mode: LaTeX

Minor modes in effect:
   tool-bar-mode: t
   encoded-kbd-mode: t
   mouse-wheel-mode: t
   menu-bar-mode: t
   font-lock-mode: t
   unify-8859-on-encoding-mode: t
   line-number-mode: t

Recent input:
- - e m a c s - f o n t - l o c k . t e x <return> M-x
f o n t - l o c k - m o d e <return> \ n o l i n k
u r l { } <left> f i l e _ n a m e _ w i t h _ u n
d e r s c r o <backspace> <backspace> o r e . t x t
C-e M-x r e p o r t - e m a SPC b u g <return>

Recent messages:
Loading tex-mode...done
Making completion list...
Loading font-lock...done
Loading jit-lock...done
mwheel-scroll: Beginning of buffer [188 times]
Making completion list...
(New file)
Font-Lock mode enabled
Loading skeleton...done
Loading emacsbug...done

Emacs-pretest-bug mailing list
------- End of forwarded message -------

reply via email to

[Prev in Thread] Current Thread [Next in Thread]