[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: vc-version-other-window

From: Kim F. Storm
Subject: Re: vc-version-other-window
Date: Fri, 08 Oct 2004 00:51:20 +0200
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/21.3.50 (gnu/linux)

Stefan Monnier <address@hidden> writes:

>>     Known bad interaction between SSH, CVS and libc.
>>     The problem is independent from Emacs.
>> Do we have an entry in PROBLEMS about this?
> No.  I thought PROBLEMS was only for problems related to build/install or to
> specific systems.
>> Is there a way we could warn the user when this might be happening?
> It's pretty difficult to detect when it might happen (it depends on the
> CVS_RSH envvar, the CVS/Root file, the version of `cvs' you're using, the
> speed of your network relative to the speed of your computer, the libc,
> ...).

Better safe than sorry...  Why can't we just use the wrapper script always?

I suggest that

a) we include the wrapper script in the emacs tar-ball (e.g. in 

b) install it as part of the installation

c) use it unconditionally to override the value of CVS_RSH if it
equals/contains 'ssh'.

BTW, INSTALL.CVS contains a note about this problem and the work-around (.

Kim F. Storm <address@hidden> http://www.cua.dk

reply via email to

[Prev in Thread] Current Thread [Next in Thread]