[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Current CVS doesn't bootstrap

From: Luc Teirlinck
Subject: Re: Current CVS doesn't bootstrap
Date: Sun, 7 Nov 2004 15:09:44 -0600 (CST)

Piet van Oostrum wrote:

   An alternative would be to remove only those .elc files that
   are older than their corresponding .el files.

That, or Andreas' suggestion, could actually be an improvement for the
proposed `make bootstrap-build', assuming our (apparent) consensus from a
previous thread got implemented.  But I believe that two problems
would remain.

It would seem that some changes in byte-compilation may require
recompiling everything.  I believe nothing can be done about that.

Before I started systematically using `make maintainer-clean', I
encountered several problems where the .elc file was wrong even though
_newer_ than the .el file.  For instance, `C-x v u' in VC produces
such situations.  I guess this problem could be avoided by manually
removing the .elc file each time after you do `C-x v u' or otherwise
cause this type of situation.  But this assume that most users are
aware of this danger.  It also is easy to forget, even if you know.
If you run Emacs from the place you built it, then you might want to
recompile instead of deleting the .elc file.  But then you also have
to also manually change the last modification time to ensure that the
.elc will not be considered newer than a changed .el at the next
update.  This starts getting tricky.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]