[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

address@hidden: Highlight/font-lock problem with non-fixed width fonts]

From: Richard Stallman
Subject: address@hidden: Highlight/font-lock problem with non-fixed width fonts]
Date: Thu, 03 Feb 2005 14:13:27 -0500

Does this problem happen in the current version?

------- Start of forwarded message -------
From: Miguel Frasson <address@hidden>
To: address@hidden
Date: Wed,  2 Feb 2005 16:07:01 +0100 (CET)
Subject: Highlight/font-lock problem with non-fixed width fonts
Sender: address@hidden
X-Spam-Status: No, hits=0.5 required=5.0
X-Spam-Checker-Version: SpamAssassin 2.55 (

This bug report will be sent to the Free Software Foundation,
not to your local site managers!
Please write in English, because the Emacs maintainers do not have
translators to read other languages for them.

Your bug report will be posted to the address@hidden mailing list,
and to the gnu.emacs.bug news group.

In GNU Emacs 21.3.1 (i386-redhat-linux-gnu, X toolkit, Xaw3d scroll bars)
 of 2004-04-15 on bugs.devel.redhat.com
configured using `configure  --host=i386-redhat-linux --build=i386-redhat-linux 
--target=i386-redhat-linux-gnu --program-prefix= --prefix=/usr 
--exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc 
--datadir=/usr/share --includedir=/usr/include --libdir=/usr/lib 
--libexecdir=/usr/libexec --localstatedir=/var --sharedstatedir=/usr/com 
--mandir=/usr/share/man --infodir=/usr/share/info --with-pop --with-sound'
Important settings:
  value of $LC_ALL: nil
  value of $LC_COLLATE: nil
  value of $LC_CTYPE: nil
  value of $LC_MESSAGES: nil
  value of $LC_MONETARY: nil
  value of $LC_NUMERIC: nil
  value of $LC_TIME: nil
  value of $LANG: en_US
  locale-coding-system: iso-latin-1
  default-enable-multibyte-characters: t

Please describe exactly what actions triggered the bug
and the precise symptoms of the bug:


I am using in some lines (section title in LaTeX-mode in new AUCTeX) a
large non-fixed width font (helvetica) (AUCTeX defaults), and I use also
pc-selection-mode.  I was in a long line, with non-fixed width font, that
is displayed in 2 lines.  I select text in this line such that text in
both displayed lines is highlighted.  Then I delete this text.  Strangely,
there is a tiny (or huge, depending on what is next) area in the end of
the line that is still highlighed.  An undo action, that puts the text
back and does _not_ select anything, does not paint in white again that

What I think that is happening: since the text is in non-fixed font, the
end of the "picture" of the last displayed character in a line does not
coincide with the frame border.  There is a white (bg color) region,
smaller in width than the next character.  This region is not correctly

A screenshot demonstrating the problem is found in 

Best regards.


Recent input:
<down> <up> <up> <home> <C-right> <C-right> <C-right> 
<C-right> <C-right> <C-right> <C-right> <end> <left> 
<left> <left> <left> <left> <left> <left> <left> <left> 
<right> <right> <right> <right> <right> <left> <left> 
<end> <left> <C-S-left> <C-S-left> <S-left> <S-left> 
<S-left> <S-left> <delete> C-_ <backspace> <right> 
<right> <right> <right> <right> <right> <left> <left> 
<left> <left> <left> <left> SPC <C-right> <left> <left> 
<left> <left> <C-S-right> <C-S-right> <C-S-right> <delete> 
SPC / <backspace> m m m m m m m m <C-S-left> <delete> 
C-_ <help-echo> <help-echo> <help-echo> <help-echo> 
<help-echo> <help-echo> <help-echo> <help-echo> <help-echo> 
<help-echo> <help-echo> <help-echo> <help-echo> <help-echo> 
<help-echo> <help-echo> <help-echo> <help-echo> <help-echo> 
<help-echo> <help-echo> <help-echo> <menu-bar> <help-menu> 

Recent messages:
Mark set
Mark set
Mark set
Mark set [2 times]
Loading emacsbug...done

Bug-gnu-emacs mailing list
------- End of forwarded message -------

reply via email to

[Prev in Thread] Current Thread [Next in Thread]