[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: `texinfo-format-buffer' doesn't fold long lines

From: Robert J. Chassell
Subject: Re: `texinfo-format-buffer' doesn't fold long lines
Date: Mon, 28 Feb 2005 15:11:34 +0000 (UTC)

Katsumi Yamaoka <address@hidden> wrote,

   In some cases, `texinfo-format-buffer' doesn't fold long lines.

   ... It happens because someone added "itemize\\|" to
   `texinfo-no-refill-regexp' as follows:

   (defvar texinfo-no-refill-regexp

Yes, the inclusion of "itemize\\|" tells Emacs not to refill lines in
an itemized list.

I have commented out that inclusion and committed the change.

So `texinfo-format-buffer' should work again as you expect.

As I wrote at the time I included it

    ... I don't think this fix should be used as is.

Evidentally, back in November 2001, a user in FSF India could not
format the then new edition of `emacs-lisp-intro.texi' using
`texinfo-format-buffer' because `texinfmt.el' created the bad line

    @end address@hidden

He was using a Microsoft operating system and thought (erroneously,
according to Eli Zaretskii) that `makeinfo' had not yet been ported.
That is why he was using the deprecated `texinfo-format-buffer'

In any event, I completely forgot about it.

You write that 

    ... texinfmt is essential to format Japanese Info files.

What needs to be changed for `makeinfo' to format them?

As Eli wrote back then,

    I'd rather advise that users to use makeinfo.  texinfmt.el doesn't
    support quite a few of the newer features ...

We should modify `makeinfo' to handle Japanese Texinfo, if need be.
`makeinfo' is faster and `texinfmt.el' was deprecated a long time ago.

    Robert J. Chassell                         
    address@hidden                         GnuPG Key ID: 004B4AC8
    http://www.rattlesnake.com                  http://www.teak.cc

reply via email to

[Prev in Thread] Current Thread [Next in Thread]