[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: New dumping problem...

From: Katsumi Yamaoka
Subject: Re: New dumping problem...
Date: Wed, 22 Jun 2005 17:20:38 +0900
User-agent: Gnus/5.110004 (No Gnus v0.4) Emacs/22.0.50 (gnu/linux)

There's no way for unprivileged users to avoid the problem that
the Fedora Core 4 eats the C-SPC key.

>>>>> In <address@hidden> Katsumi Yamaoka wrote:

>>     BTW, FC4 eats the C-SPC key for the `iiimx' program which is the
>>     input method for (at least?) Japanese text by default, so I
>>     couldn't use C-SPC for `set-mark-command' in Emacs.  Liang Zhao
>>     kindly told me that it can be solved by removing `<Ctrl>space'
>>     from the /usr/lib/X11/app-defaults/Iiimx file, and I put it into
>>     practice.

>> That requires you to be root.  Is there something an unprivileged
>> user can do, to achieve the same result?

> Now I cannot reproduce the problem that FC4 eats the C-SPC key
> even though I put the Iiimx file back into the default.

While I always use the GNOME desktop, I could reproduce the
problem by using the KDE desktop.  Modifying the Iiimx resource
file is effective there, but only that file is read when the
user logged in.  It is ineffective to load the Iiimx file or the
~/.Xdefaults file by xrdb as well as the GNOME desktop.
Furthermore, the `iiimf-le-tools'[1] command  doesn't work at
both the desktops.

[1] http://www.fedora.redhat.com/projects/i18n/iiimf-faq.html

By the way, Emacs built with the `--without-xim' option has no
problem for fetching the C-SPC key.  I built Emacs 21.4 and
22.0.50 and confirmed it.  I think that it can become the
default since Emacs provides the input methods of practical use.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]