[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Better default values for tooltip padding and `tooltip-hide-delay'?

From: Luc Teirlinck
Subject: Re: Better default values for tooltip padding and `tooltip-hide-delay'?
Date: Tue, 11 Oct 2005 18:46:18 -0500 (CDT)

   For instance, the menu-bar item

     Visit New File

   has the tooltip

     Read and create a file or edit it

   Does the tooltip really impart any information that the item

Even in this instance, the answer is yes, it does, but not as clearly
as it should.  "Visit New File" is confusing, because that is not what
the menu item does.  It runs `C-x C-f'.  In at least one other editor
(gedit) the `File->New' menu item _always_ creates a _new_ file
and asks you for a name when you want to save it.  It is somewhat
analogous to `C-x b' except that it always creates _new_ buffers
"Untitled 1", "Untitled 2" and so on, without prompting the user for a
buffer name (except on saving).

Hence one _definitely_ needs the help echo and it should even be more
explicit.  What about changing it to:

"Create a new file, or read an existing file, and edit it."

I believe however, that the change from "Open File" running `C-x C-f'
in 21.3 and earlier to the present "Visit New File" running `C-x C-f'
and "Open File" running a variant of `C-x C-f' with different
minibuffer completion must have been due to a discussion with a less
experienced Emacs users, where once again the participants in the
discussion completely misunderstood each other.  The change makes the
_names_ in the File menu more similar to the _names_ in less advanced
editors, but since the _functionality_ is very different, I doubt that
this is an improvement.  The fact that these two menu items do nearly
the same thing and have very different names is quite confusing too.
What is the difference between visiting a file and opening a file?
It also has the disadvantage that "Open File" means something
different depending on the Emacs version, again with the possibility
of confusing people.

What about changing the item names "Visit New File" into "Open New or
Existing File" and "Open File" into "Open Existing File".

That makes it clear that the second is a specialization of the first.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]