[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [NT] Problem with `man' function

From: Eli Zaretskii
Subject: Re: [NT] Problem with `man' function
Date: Thu, 11 May 2006 06:49:11 +0300

> From: Dave Abrahams <address@hidden>
> Date: Wed, 10 May 2006 20:54:16 +0000 (UTC)
> >     sed: -e expression #1, char 1: unknown command: `''
> >     awk: '
> >     awk: ^ invalid char ''' in expression
> > 
> >     process exited abnormally with code 1
> > 
> > The messages from Sed and Awk say quite unequivocally that the problem
> > is with the quoting style: Windows shells and programs don't support
> > the '..' quoting that man.el uses.
> Using the other quoting made no difference whatsoever for me.
> > I tried to replace '..' quoting with ".." quoting, but then bumped
> > into other bugs, this time in Sed.  It sounds like the GnuWin32 port
> > of Sed is hopelessly broken.  Or it could be a bug with cmdproxy.exe,
> > I really don't have time to dig into that.
> > 
> > Perhaps with the Cygwin ports you have man.el will work if you replace
> > '..' quoting with ".." quoting in the Sed and Awk scripts used by
> > man.el.  Could you perhaps try that?
> Tried it, to no avail.

Please show the modified portion in man.el with this change.  Perhaps
you didn't get all the escaping right.

> > Failing that, I suggest to use woman.el.
> Aww, this is discouraging.

Why?  There's nothing man.el can do that woman.el cannot.

> Can't you suggest a place to breakpoint so we can look at what's
> coming out of awk?

>From the above error message it's clear that nothing comes out of Awk,
since it barfs because of a syntax error.

But if you do manage to run Awk without an error message, just add a
`message' line that displays its output after it returns.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]