[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problems with HOME on w32

From: Eli Zaretskii
Subject: Re: Problems with HOME on w32
Date: Thu, 18 May 2006 22:31:25 +0300

> Date: Thu, 18 May 2006 19:47:01 +0200
> From: Lennart Borgman <address@hidden>
> I traced Emacs22 file access with NTFILMON 
> (http://www.sysinternals.com). I found that Emacs try to query 
> information on |C:\.emacs| (after one on |C:\|) and fails with buffer 
> overflow (I guess the structure passed to store query result is too 
> small). Seems something goes bad inside Emacs so that HOME is corrupted.
> It should be noted that without a |C:\.emacs| file, everything works and 
> then .emacs file is expected in %APPDATA% directory for and 
> HOME env. var point to this place too.
>  >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
> I tested and got the same result with GNU Emacs 
> (i386-mingw-nt5.0.2195) of 2006-05-13.

Lennart, could you please explain in plain English what is the
problem?  I'm sorry, but I cannot make heads or tails out of the
original report you cited, nor can I understand the precise recipe to
reproduce the bug.  Is the reason the non-ASCII characters used in the
value of HOME? or is that the symptom of corruption? what does probing
C:\.emacs have to do with this? etc., etc.

Since you say that you can reproduce the problem with a fairly recent
build, please give a precise recipe for that, including what should be
the value of HOME, which .emacs files should be present in what
directories, etc.

And please don't use NTFILMON or similar tracing tools; instead, if
you need to see what is going on under the hood, please step with a
debugger into the relevant code (it's in the function init_environment
defined on w32.c), and tell what you see.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]