[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Did something change with respect to Emacs idle loop:

From: T. V. Raman
Subject: Re: Did something change with respect to Emacs idle loop:
Date: Sat, 23 Sep 2006 10:55:52 -0700

Hi, to give more details: I'm not able to reproduce this error on
my laptop --- IBM thinkpad running FC3. On my desktop machine --
amd64 running 32bit Ubuntu the problem appears to be happening

Couple of additional bits re mplayer:

I use the -slave option so it can be controlled via the keyboard.

mplayer run in this manner from start-process *always* exhibits
the following behavior:
If emacs stomps responding to the keyboard e.g. when some other
process is waiting for the network e.g. nfs disks, mplayer output
stops. Note that this is independent of the new bizarre behavior
 we're tracking down this time around --- I mention it because it
 might be relevant.

My suspicion is that  when this supposed new bug triggers mplayer
locks up in a manner similar to it pausing  when you get the nfs
type problem.

To clarify the nfs-related issue above:

You'll actually see this when mplayer is playing something off of
the local disk while emacs is waiting on an nfs disk  

>>>>> "Chong" == Chong Yidong <address@hidden> writes:
    Chong> Richard Stallman <address@hidden> writes:
    >> Symptoms: Run processes like mplayer via start-process
    >> from inside emacs, e.g. playing an mp3 file --- output
    >> comes to a stop after a fixed length of time -- typically
    >> about a minute. Any form of kbd activity --- even the
    >> first key in a multi-key sequence -- gets things unwedged
    >> i.e. the mp3 stream continues to play.
    >> Does anyone else observe this problem?
    Chong> I've tried playing an album through Emacs (today's
    Chong> CVS) like this:
    Chong>   (apply 'start-process (append (list "my-process" nil
    Chong> "/usr/bin/mplayer") (cdr (cdr (directory-files
    Chong> "/home/cyd/music/aq" t)))))
    Chong> 15 minutes later, it's still playing; I observe no
    Chong> freeze in the output.  Do all subprocess all
    Chong> eventually stop for you, or does it happen only some
    Chong> of the times you run a subprocess?  I've tried this 3
    Chong> times: on X in an X window, in an xterm with "emacs
    Chong> -nw", and on the Linux console.
    Chong> _______________________________________________
    Chong> Emacs-devel mailing list address@hidden
    Chong> http://lists.gnu.org/mailman/listinfo/emacs-devel

Best Regards,

Email:  address@hidden
WWW:    http://emacspeak.sf.net/raman/
AIM:    emacspeak       GTalk: address@hidden
PGP:    http://emacspeak.sf.net/raman/raman-almaden.asc
Google: tv+raman 
IRC:    irc://irc.freenode.net/#emacs

reply via email to

[Prev in Thread] Current Thread [Next in Thread]