[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Should libXt-devel be required to build Emacs?

From: Chong Yidong
Subject: Re: Should libXt-devel be required to build Emacs?
Date: Thu, 21 Dec 2006 10:25:43 -0500
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/22.0.92 (gnu/linux)

Richard Stallman <address@hidden> writes:

>     I report this using autoconf 2.59. So this bug will exist in the
>     pretest.
> It appears that we need to switch to using Autoconf 2.61, for the
> pretests and releases.
> And this line in configure.in
>     AC_PREREQ(2.54)dnl
> should be updated to say 2.61.

There's a problem with this: Autoconf 2.61 was only released in
November this year, and it requires a new version of M4 (1.4.8), which
in turn requires a new libc6.  Most existing GNU/Linux distributions
won't have these packages (at least in their "stable" branches).

I could try to install these packages, but it would be a major hassle
because the libc6 requirement would effectively require an entire-OS
upgrade.  (This would be a hassle for any other developer who may want
to regenerate configure).

I don't think this bug is serious enough to warrant switching autoconf
versions, especially since we don't know what new bugs the new
autoconf version might introduce.  I suggest simply documenting this
in PROBLEMS and recommending the new version of autoconf there.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]