[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Bug: can not start a w32 GUI program from Emacs

From: Lennart Borgman (gmail)
Subject: Re: Bug: can not start a w32 GUI program from Emacs
Date: Wed, 27 Dec 2006 03:30:09 +0100
User-agent: Thunderbird (Windows/20061207)

Lennart Borgman (gmail) wrote:
I have been trying different ways to start explorer.exe from Emacs on w32. I can not find any way that works. It is a quite annoying bug.

I suspect this has something to do with the code in w32proc.c that defines

  start.hStdInput = GetStdHandle (STD_INPUT_HANDLE);
  start.hStdOutput = GetStdHandle (STD_OUTPUT_HANDLE);
  start.hStdError = GetStdHandle (STD_ERROR_HANDLE);

This is done even if Emacs thinks it is a GUI app. Is this the problem? Why is this handles set also for GUI programs.

It seems to be more complicated than I thought. Before I could not start for example Windows Explorer by

  (call-process "explorer.exe" nil 0 nil ".")
  (call-process "cmd.exe" nil 0 nil "/c" "explorer .")
  (start-process "some name" nil "cmd.exe" "/c" "explorer.exe" ".")

None of them worked. A window was opened, but it was blank or rather transparent. And in Task Manager was windows did not have the Explorer icon.

Now, after reboot they all work. Something is however wrong, but what?

This is on Windows XP (all the latest patches applied of course), using CVS Emacs a few days old.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]