[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Image file name extension not recognized

From: Vinicius Jose Latorre
Subject: Re: Image file name extension not recognized
Date: Sat, 03 Feb 2007 00:35:40 -0200
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20070111 SeaMonkey/1.1

Vinicius Jose Latorre wrote:
Chong Yidong wrote:
Vinicius Jose Latorre <address@hidden> writes:

The image-type-header-regexps variable has the value:

 '(("\\`/[\t\n\r ]*\\*.*XPM.\\*/" . xpm)
   ("\\`P[1-6]" . pbm)
   ("\\`GIF8" . gif)
   ("\\`\211PNG\r\n" . png)
   ("\\`[\t\n\r ]*#define" . xbm)
   ("\\`\\(MM\0\\*\\|II\\*\0\\)" . tiff)
   ("\\`[\t\n\r ]*%!PS" . postscript)
   ("\\`\xff\xd8" . (image-jpeg-p . jpeg)))

Where image-jpeg-p is a function.

I just type  M-x debug-on-entry RET image-jpeg-p RET

Then tried to open the file again and image-jpeg-p is not called.

I cannot reproduce this.  I also have files saved with extension .JPG,
and image-jpeg-p does get called.  Can you try rebuilding Emacs from
the latest CVS sources and trying with "emacs -Q"?

I've just downloaded via cvs the latest Emacs 22 version and rebuild it.

emacs -Q

The same result.

I've just noticed the echo area and now has the following message:

   Type C-c C-c to view as an image.

Typing C-c C-c, the image is ok.

The behavior above is the same if the image file has .jpg or .JPG extension.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]