[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: table cell menu does not appear at the menubar

From: Tak Ota
Subject: Re: table cell menu does not appear at the menubar
Date: Mon, 21 May 2007 17:31:12 -0700 (PDT)

Thanks for the tip.  If I don't see the problem under debugger for
another few days I'll start investigating in other ways.


Tue, 22 May 2007 00:36:24 +0200: "Lennart Borgman (gmail)" <address@hidden> 

> I have no idea about that, but the problem I mentioned earlier with 
> menus on w32 is a race  problem/sync problem (or whatever the correct 
> term is).
> It might be difficult to catch such problems with the debugger of 
> course. I inserted trace output to the console to catch it.
> Tak Ota wrote:
> > Since I freshly got the completely source from CVS Friday (05/18/07) I
> > have built it and been running it under GDB.  So far I haven't seen
> > the problem yet.  Has anyone changed something that might have fixed
> > this stuck menu problem?
> > 
> > -Tak
> > 
> > Fri, 18 May 2007 19:08:57 -0400: Richard Stallman <address@hidden> wrote:
> > 
> >>     2. When the problem once starts menubar contents do not change
> >>        regardless of the mode where point is at.  The last menubar content
> >>        is stuck.  The last remaining menu responds to mouse event and
> >>        functions correctly.
> >>
> >> menu_bar_items is the function that is supposed to make a list of
> >> all the keymaps to be processed.  So the problem is either there
> >> or in or within a function that calls it.
> >>
> >> When the problem happens, can you see if and when menu_bar_items
> >> gets called?  And when it calls get_local_map, what args does it use
> >> and what value does it get?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]