[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Post-22.1 development?

From: Richard Stallman
Subject: Re: Post-22.1 development?
Date: Sun, 17 Jun 2007 17:49:35 -0400

    This means that any libraries or other features we might want to add (beyond
    those "really important") will need to work with unicode-2 Emacs. I know
    already that some of my own code, which works perfectly well with Emacs 22,
    will not work as is with unicode-2 Emacs. For example, my code for zooming
    frames (default font) breaks.

We are going to merge unicode-2 pretty soon.  Within a few months.
Any other feature that we add will have to be adapted, one way or
another, to work with unicode-2, by that time.

If a feature has conflicts with unicode-2, it makes little sense to
rush to install it in the trunk.  That would just add to the size of
the job of merging the unicode-2 branch.  It is much better to adapt
the other feature _now_ to work with unicode-2, and install it after
that.  That way, the work can be done in parallel.

You could start doing this now.

Meanwhile, if a new feature won't make the unicode-2 merge harder,
then we can install it now into the trunk.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]