[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Recognizing obsolete external package versions

From: Richard Stallman
Subject: Re: Recognizing obsolete external package versions
Date: Mon, 13 Aug 2007 20:28:24 -0400

    > That code seems basically right
    > except that I would rather it avoid calling eval.
    > It should give the name of a variable, and the values that are bad.
    IIRC, we discurage inclusion of version strings in packages.

We discurage inclusion of version variables
in packages that are part of Emacs.  However, the use of this
feature is for packages that are not part of Emacs.
They normally do have version numbers.

    For the CUA-mode check, there is no such version variable ... instead, it
    is simply the presence of the `CUA-mode' feature which triggers the warning.

That is a valid point.

    What method would you use to trigger the checking _before_ the load
    (even before reading the file)?

It would need new code at the C level in Fload, I think.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]