[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

address@hidden: Eamcs 22.1 comint-scroll-show-maximum-output bug]

From: Richard Stallman
Subject: address@hidden: Eamcs 22.1 comint-scroll-show-maximum-output bug]
Date: Sat, 25 Aug 2007 00:07:16 -0400

[I sent this message a week ago but did not get a response.]

Would someone please DTRT and ack?

------- Start of forwarded message -------
X-Spam-Status: No, score=0.5 required=5.0 tests=DNS_FROM_RFC_ABUSE,
        UNPARSEABLE_RELAY autolearn=no version=3.1.0
Date: Thu, 16 Aug 2007 20:28:11 -0700
From: William Paul Vrotney <address@hidden>
To: address@hidden
FCC: ~/rmail/sent
Subject: Eamcs 22.1 comint-scroll-show-maximum-output bug


First noticed in Emacs 22.1.  The comint variable


does not work as documented when set to nil.  For example when setting this
variable to nil when using M-x shell the Emacs 22.1 manual says

        41.7 Shell Mode Options

           If `comint-scroll-show-maximum-output' is non-`nil', then arrival
        of output when point is at the end tries to scroll the last line of
        text to the bottom line of the window, showing as much useful text
        as possible.  (This mimics the scrolling behavior of most
        terminals.)  The default is `t'.


    Emacs source: from http://ftp.gnu.org emacs-22.1.tar.gz
    Build: Simply: configure; make; make install;
    Emacs M-x version: Its value is "22.1.1"
    Operating System: Fedora core 3
    Emacs Invocation: emacs -q

    Then if you then do the following

        M-x set-variable comint-scroll-show-maximum-output nil
        M-x shell

    then once the shell buffer becomes full every output still scrolls the
    last line of text to the bottom as it does when
    comint-scroll-show-maximum-output is set to t.

    I've tried setting this variable in all possible ways: before/after
    running M-x shell and using 'setq' in ~/.emacs, 'M-x set-variable' and
    'M-x customize.  But with all the same results as explained above.

OTHER INFORMATION:  The M-x shell defaults to running the bash shell.


    When I run the command M-x shell with comint-scroll-show-maximum-output
    set to nil the shell buffer window does not show the first line of bash
    shell output.  In my case it the first line of my two line prompt.  If I
    type M-x recenter then the first line of bash shell output comes into
    view in the buffer window.


    If I use Emacs 22.1 but load in my ~/.emacs the comint.elc from Emacs
    21.3 then all works fine as it did for Emacs 23.1 and earlier.

bug-gnu-emacs mailing list
------- End of forwarded message -------

reply via email to

[Prev in Thread] Current Thread [Next in Thread]