[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Emacs crashed trying to connect to X display

From: Chris Moore
Subject: Emacs crashed trying to connect to X display
Date: Sat, 8 Sep 2007 17:24:56 +0200

I usually run Emacs inside GNOME, but today I'm ssh'ed into the box, running Emacs in an ssh terminal window.
I ran "svn ci" to commit a bunch of changes to subversion, and Emacs crashed, leaving the terminal looking like this:

address@hidden:~/project$ svn ci
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified Bot (1164,0)   (Shell:run)----Sat Sep  8 17:19 0.14-------------------------------------------------------------------------------
(emacs:30371): Gtk-WARNING **: cannot open display: :0.0

I have the 'EDITOR' environment variable set to point to a shell script which does:

/usr/local/bin/emacsclient "$@" ||
/usr/local/bin/emacs       "$@"

and I also have "DISPLAY=:0.0" in the environment (which I probably shouldn't).

But when I run "emacs" in the ssh session, it runs the console version of Emacs, which is what I was expecting from the emacsclient program as well.  If it can't connect to an X server, it just crashes Emacs - that can't be the desired behaviour, can it?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]