[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Another VC terminology change?

From: Eric S. Raymond
Subject: Re: Another VC terminology change?
Date: Thu, 11 Oct 2007 14:05:18 -0400
User-agent: Mutt/1.5.15+20070412 (2007-04-11)

Stefan Monnier <address@hidden>:
> Not about "checkout" which sometimes means "update" and sometimes "get".

Yes, I'm aware of that problem.  I  need to do some comparative study 
of VCSes and think about their typologies some more before pursuing this.

> But yes, "checkin" should be replaced by "commit".
> This said, I don't know if we should change it only in the doc, or also in
> the code, especially in the part of the code that interacts with the user
> (i.e. commands) or the backends: I think it's important to make sure that
> a single backend can work both with the new and the old VC.

That compatibility is gone beyond retrieval.  It was already doomed when
I moved the backends to taking fileset args, and I added another
layer of impossible with the version -> revision terminology change.

So if we're going to do this change at all, it might as well be in docs and
code both.  Maintaining consistency will save us problems later.

But I need to some more thinking before moveing on this.
                <a href="http://www.catb.org/~esr/";>Eric S. Raymond</a>

reply via email to

[Prev in Thread] Current Thread [Next in Thread]