[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: 23.0.60; Umlaut chars with 'face property set to 'bold aren't displa

From: Tassilo Horn
Subject: Re: 23.0.60; Umlaut chars with 'face property set to 'bold aren't displayed in bold with --disable-font-backend
Date: Fri, 09 May 2008 17:30:52 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.0.60 (gnu/linux)

Tassilo Horn <address@hidden> writes:

>>> I use a very recent CVS checkout compiled with --disable-font-backend.
>>>      (insert (propertize "testÜÄÖüäößtest" 'font-lock-face 'bold))
>>> The umlauts between the "test"s won't be displayed in bold, although
>>> the misc-fixed font contains bold versions of all those chars.
>> Can you reproduce this without compiling with --disable-font-backend,
>> or in Emacs 22?
> When compiling without --disable-font-backend all chars are bold.

Some short addition: When compiled without --disable-font-backend

  (insert (propertize "testÜÄÖüäößtest" 'font-lock-face 'bold))

makes all chars bold when using

  Emacs.FontBackend: x
  Emacs.Font: -misc-fixed-medium-r-*-*-15-*-*-*-*-*-iso10646-1

in my ~/.Xdefaults, which is different from what you get with

But for example in latex-mode when editing LaTeX files the text in

  \section{foo bar baz föö bär bäz}

is displayed in a bigger font (font-latex-sectioning-X-face), but again,
the umlauts are not.  The same applies to emacs compiled with

describe-face lists the correct faces, but what's actually displayed is
the default face with only the foreground color of the sectioning face.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]