[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

23.0.60; [nxml] BOM and utf-8

From: Patrick Drechsler
Subject: 23.0.60; [nxml] BOM and utf-8
Date: Sat, 17 May 2008 14:31:39 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.0.60 (gnu/linux)

Please write in English if possible, because the Emacs maintainers
usually do not have translators to read other languages for them.

Your bug report will be posted to the address@hidden mailing list.

Please describe exactly what actions triggered the bug
and the precise symptoms of the bug:


is the attached xml file (simple.xml) really invalid (as indicated by
nxhtml) or is this a bug in nxhtml?

describe-char on the first symbol gives (I replaced the BOM part with

|         character: XXX (65279, #o177377, #xfeff)
| preferred charset: unicode (Unicode (ISO10646))
|        code point: 0xFEFF
|            syntax: w  which means: word
|       buffer code: #xEF #xBB #xBF
|         file code: #xEF #xBB #xBF (encoded by coding system utf-8-unix)
|           display: no font available
| Character code properties are not shown: customize what to show
| There is an overlay here:
|  From 1 to 2
|   category             rng-error
|   help-echo            "Missing space after name"
|   priority             1
| There are text properties here:
|   auto-composed        t
|   fontified            t

describe-current-coding-system also looks correct:

| Coding system for saving this buffer:
|   U -- utf-8-unix (alias: mule-utf-8-unix)



If Emacs crashed, and you have the Emacs process in the gdb debugger,
please include the output from the following gdb commands:
    `bt full' and `xbacktrace'.
If you would like to further debug the crash, please read the file
/home/patrick/prg/stow/emacs-devel/share/emacs/23.0.60/etc/DEBUG for 

In GNU Emacs (i686-pc-linux-gnu, GTK+ Version 2.12.9)
 of 2008-05-08 on golem
Windowing system distributor `The X.Org Foundation', version 11.0.10400090
configured using `configure  '--prefix=/home/patrick/prg/stow/emacs-devel''

Important settings:
  value of $LC_ALL: nil
  value of $LC_COLLATE: nil
  value of $LC_CTYPE: nil
  value of $LC_MESSAGES: nil
  value of $LC_MONETARY: nil
  value of $LC_NUMERIC: nil
  value of $LC_TIME: nil
  value of $LANG: de_DE.UTF-8
  value of $XMODIFIERS: nil
  locale-coding-system: utf-8-unix
  default-enable-multibyte-characters: t

Major mode: nXML

Minor modes in effect:
  delete-selection-mode: t
  show-paren-mode: t
  savehist-mode: t
  pc-selection-mode: t
  iswitchb-mode: t
  display-time-mode: t
  shell-dirtrack-mode: t
  tooltip-mode: t
  mouse-wheel-mode: t
  menu-bar-mode: t
  file-name-shadow-mode: t
  global-font-lock-mode: t
  font-lock-mode: t
  blink-cursor-mode: t
  global-auto-composition-mode: t
  auto-composition-mode: t
  auto-encryption-mode: t
  auto-compression-mode: t
  column-number-mode: t
  line-number-mode: t
  transient-mark-mode: t

Recent input:
M-x C-g <f10> <menu-bar> <help-menu> <send-emacs-b

Recent messages:
Loading time...done
Loading iswitchb...done
Loading pc-select...done
Loading savehist...done
Loading paren...done
Emacs startup time: 3 seconds.
For information about GNU Emacs and the GNU system, type C-h C-a.
Using vacuous schema
Missing space after name

Attachment: simple.xml
Description: application/xml

reply via email to

[Prev in Thread] Current Thread [Next in Thread]