[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Changes 2009-07-15/16 in branch?

From: YAMAMOTO Mitsuharu
Subject: Re: Changes 2009-07-15/16 in branch?
Date: Thu, 23 Jul 2009 21:46:48 +0900
User-agent: Wanderlust/2.14.0 (Africa) SEMI/1.14.6 (Maruoka) FLIM/1.14.8 (Shij┼Ź) APEL/10.6 Emacs/22.3 (sparc-sun-solaris2.8) MULE/5.0 (SAKAKI)

>>>>> On Thu, 23 Jul 2009 07:22:55 -0400, Adrian Robert <address@hidden> said:

> Hello Yamamoto-san, Did you mean to check the changes below into the
> branch?  I *think* these are pretty safe, but it seems a bit close
> to release for such feature changes, even in the name of
> standardization.  My vote would be to do these on trunk only for
> now.

Chong Yidong already made a query to me via a private mail.  Below is
my reply:

  It's essential to make these changes in the release branch so users
  may not use the incompatible formats by accident and introduce
  compatibility problems when they are removed in some future version.
  Upcoming version is the first one for the NS port.  Effectiveness is
  much lowered if such changes are deferred to the later versions.

  I've warned about such incompatibility issues that I think
  indispensable for the first official release version, but the author
  has not tried to address them (not just for this one!).

  Even if by any chance there's overlooked code as you say, it's only
  in the NS-specific part and relatively minor compared with total
  unstableness of the port itself.  Removing incompatible features at
  this timing is much more important unless the port is marked

  Anyway, let's wait at least a few days before making any changes in
  this respect.

> Also:

> ns_get_color(): Shouldn't the description comment for ns_get_color()
> be updated further?  It looks like something was just chopped off,
> leaving the rest making little sense.  What is the bug or problem
> this change fixes?

> ns_color_to_lisp(): The function could be simplified now that you
> have eliminated a special case.

I know the changes are not optimal.  But I wanted to keep them quite
straightforward so as to avoid regression.

> nsfont_draw(): Would setting the foreground instead of the
> background color to the bitmap constitute a corrected
> implementation?

I don't know if I understand your intention correctly from the above
sentence.  But if you believe you understand stippling correctly this
time, maybe you can make the change into the trunk.

> ns-set-background-alpha: The implementation you just removed was
> superior to that for (set-frame-parameter nil 'alpha ##): it does
> not alter the alpha of the titlebar, scrollbars, modeline, or text.
> This makes it usable, instead of a curiosity.  It also provides
> access via an interactive function.  The correct fix would be to
> improve the (set- frame-parameter) version, not remove this while no
> alternative exists for users.

I knew their difference.  I removed it because it belongs to "NS-only
implementation for features that are not inherently specific to NS."

I think it's really bad for the "first-class" port to have such
features because they may be superseded in a platform-independent way
by some future versions and that introduces unnecessary

                                     YAMAMOTO Mitsuharu

reply via email to

[Prev in Thread] Current Thread [Next in Thread]