[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: colours in client on xterm (if an X frame is open at same time)

From: Dan Nicolaescu
Subject: Re: colours in client on xterm (if an X frame is open at same time)
Date: Fri, 8 Jan 2010 08:48:06 -0800 (PST)

Jan Djärv <address@hidden> writes:

  > Ulrich Mueller skrev:
  > >>>>>> On Thu, 7 Jan 2010, Dan Nicolaescu wrote:
  > >
  > >> Green is not the default face for the modeline for any display, so
  > >> something is strange in your setup.
  > >
  > > Right, this particular colour was taken from my X settings
  > > ("*HighlightColor: DarkSeaGreen2"). I've repeated the test with empty
  > > X resources, new screenshots are here:
  > > <http://dev.gentoo.org/~ulm/screenshot/>
  > >
  > > Anyway, my point was, why are the colours _different_ in the second
  > > case? Especially, why is the background grey?
  > >
  > The terminal frame defines the default face with unspecified-bg.
  > But when you start the X frame, the default face has background white
  > (or rather the X pixel value for white).
  > This face is still realized when you start the second terminal
  > face. Apparently pixel value for "white" in X translates to gray in an
  > xterm.  I don't know exactly how the pixel values in the terminal case
  > gets translated.

I only have access to 23.1 at the moment, and here the foreground and
background are unspecified-bg/fg in the second terminal frame.
Are you saying that is not the case in trunk now?  That seems to be the
problem then.
For a terminal the functions lisp/term/tty-colors.el:tty-color* do the 

reply via email to

[Prev in Thread] Current Thread [Next in Thread]