[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Fwd: Building Emacs trunk on Windows 7, using MinGW + MSYS

From: Dani Moncayo
Subject: Fwd: Building Emacs trunk on Windows 7, using MinGW + MSYS
Date: Mon, 4 Jul 2011 14:19:58 +0200


Yesterday I sent the bellow message to help-emacs-windows mailing
list, but It still doesn't appear in the archives (strange), so I'm
forwarding it here to emacs-devel (which also seems more appropriate,
since it is not a user-level question).

---------- Forwarded message ----------
From: Dani Moncayo <address@hidden>
Date: Sun, Jul 3, 2011 at 16:50
Subject: Building Emacs trunk on Windows 7, using MinGW + MSYS
To: address@hidden


I'm trying to build Emacs (the latest trunk version) on my system
(Windows 7 64-bit). I've tried to follow the instructions in
"INSTALL.BZR" and "nt/INSTALL", but I still haven't found the way.

Here's what I've tried:
1. I've installed the latest MinGW/MSYS in folder "C:\MinGW".
2. I've added "C:\MinGW\bin;C:\MinGW\msys\1.0\bin" to the system PATH.
3. I've tested the environment by writing and building a "hello world"
C program.  It works fine.
4. I've pulled the latest Emacs trunk to "C:\Emacs\trunk".
5. From a console (cmd.exe), I've executed these commands:
 5.1 cd C:\Emacs\trunk\nt
 5.2 configure --without-xpm --without-png --without-jpeg
--without-tiff --without-gif > configure.log 2>&1
 5.3 make bootstrap > make.log 2>&1

I'm attaching the output from configure and make commands
("configure.log" and "make.log").

The make command stops after a while.  It seems that a new session of
cmd.exe has been started, and is waiting for input.  I know this
because I see two "cmd.exe" processes in the task manager, and also
the last part of make's output suggests that.

Do you know what am I doing wrong?


Dani Moncayo

Attachment: configure.log
Description: Binary data

Attachment: make.log
Description: Binary data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]