[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Gdb in emacs 24

From: Lluís
Subject: Re: Gdb in emacs 24
Date: Sun, 23 Oct 2011 21:47:01 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.3 (gnu/linux)

Stefan Monnier writes:

>> Right, both were assuming the use of the "interpreter-exec" command.
> Makes sense.  But as I said, I think for 24.1, it's too late to make
> this change.


I've attached a series of patches to:

* Check if we are using a supported gdb interpreter

* Disable gdb annotations

* gdb >= 7 should be considered recent
  In addition, command "maint set linux-async on" does not exist.

Feel free to change the code, as I don't know if my approach is the cleanliest
way of doing it.


Attachment: 00-check-mi.patch
Description: Text Data

Attachment: 01-unannotate.patch
Description: Text Data

Attachment: 02-todos.patch
Description: Text Data

 "And it's much the same thing with knowledge, for whenever you learn
 something new, the whole world becomes that much richer."
 -- The Princess of Pure Reason, as told by Norton Juster in The Phantom

reply via email to

[Prev in Thread] Current Thread [Next in Thread]