[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: emacs-20111018-r106127 Windows Binaries

From: Seweryn Kokot
Subject: Re: emacs-20111018-r106127 Windows Binaries
Date: Mon, 24 Oct 2011 14:56:40 +0200

On Mon, Oct 24, 2011 at 2:36 PM, Eli Zaretskii <address@hidden> wrote:
>> Date: Mon, 24 Oct 2011 14:14:00 +0200
>> From: Seweryn Kokot <address@hidden>
>> Cc: address@hidden, address@hidden
>> I read somewhere that for the current devel emacs, libpng 1.4 or later
>> is required.
> Not required, _recommended_.


I read it in emacs-24.0.90/README.W32 file which is published with the
emacs binaries (both pretest and current trunk):

It says:

* Image support
      PNG: requires the PNG reference library 1.4 or later, which will
      be named libpng14.dll or libpng14-14.dll.  LibPNG requires zlib,
      which should come from the same source as you got libpng.
      Starting with Emacs 23.3, the precompiled Emacs binaries are
      built with libpng 1.4.x and later, and are incompatible with
      earlier versions of libpng DLLs.  So if you have libpng 1.2.x,
      the PNG support will not work, and you will have to download
      newer versions.

Anyway for the future it would be good to compile emacs sources with
libpng14. Thanks.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]