[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Emacs 23.4 Updated Windows Binaries published

From: Lennart Borgman
Subject: Re: Emacs 23.4 Updated Windows Binaries published
Date: Sun, 5 Feb 2012 20:10:50 +0100

On Sun, Feb 5, 2012 at 17:52, Eli Zaretskii <address@hidden> wrote:
>> Date: Sun, 05 Feb 2012 17:34:22 +0100
>> From: Angelo Graziosi <address@hidden>
>> Christoph Scholtes wrote:
>> > The binaries were built using the following libraries:
>> > giflib-4.1.4-1
>> > jpeg-6b-4
>> > libXpm-3.5.8
>> > libpng-1.4.3-1
>> > tiff-3.8.2-1
>> > zlib-1.2.5-2
>> Does an user need those libraries at run-time?
> No, Emacs will run even without them.  But some features, like support
> for displaying the corresponding image types, will not be available.

So if the question was "any user" than the answer is "yes" ... ;-)

> That means unnecessary complications for the volunteers who produce
> the binaries, see the recent threads here (about GnuTLS, but not only
> about it).  For starters, we need to provide sources as well, and that
> might be tricky legal-wise.

I have not been following this particular thread, but my understanding
is that only a link to the relevant sources is needed now - if we can
guarantee that this works. (This was my understanding of a message
from RMS quite some time ago. I might have misunderstood it, though.)

A real problem is however to keep the libraries updated. There could
be security problems for some of them and that requires an easy way to
remind about security updates and do them.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]