[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Eshell and Sudo

From: Aidan Gauland
Subject: Re: Eshell and Sudo
Date: Sun, 17 Feb 2013 08:44:17 +1300
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.3.50 (gnu/linux)

Michael Albinus <address@hidden> writes:
> Ian D <address@hidden> writes:
>> Eshell Developers,
> Hi Ian,
>>         I tried running Emacs without a configuration file, using -q,
>>         and got the same thing.  Does anyone know why it's doing this?
> I guess you mean -Q. Anyway, same result here.
> Even stranger, if I preload tramp by "emacs -Q -l tramp", I get random
> results:

No one, not even John Wiegley, seems to know why sudo/su works for some
people and not others.  Debugging Eshell sudo/su is on my TODO list.  I
don't even know whether this is an Eshell problem or a TRAMP problem.  I
suspect tramp, since Eshell is only calling TRAMP (which should *not* be
blowing up like it does for some people).

Aidan Gauland

reply via email to

[Prev in Thread] Current Thread [Next in Thread]