emacs-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Using the GNU GMP Library for Bignums in Emacs


From: Tom Tromey
Subject: Re: Using the GNU GMP Library for Bignums in Emacs
Date: Fri, 06 Jul 2018 22:27:25 -0600
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.1.50 (gnu/linux)

Tom> 1. Should the C core change the names of things like NUMBERP to FIXNUMP?
Tom> Similarly should make_number -> make_fixnum?

Paul> Yes, we should keep things clear in the C core, and this would
Paul> definitely be clearer. Please do it as a separate commit, though.

Yes, definitely.  I ran this and got a big patch:

  sed -i 's/INTEGERP/FIXNUMP/g' *.[ch]
  sed -i 's/make_number/make_fixnum/g' *.[ch]
  sed -i 's/CHECK_NUMBER/CHECK_FIXNUM/g' *.[ch]

I wasn't sure if I should try to rename NUMBERP or NATNUMP.
On the one hand they are really checking only for fixnums.
On the other hand, the logical names seem like they'd be unwieldy.

Also I was not sure what to do with calls like:

#define lisp_h_CHECK_FIXNUM(x) CHECK_TYPE (FIXNUMP (x), Qintegerp, x)

Here it is using 'integerp, but that will be a bit false.



Also I found the bug with arith_driver and now the branch can bootstrap
again.

Tom



reply via email to

[Prev in Thread] Current Thread [Next in Thread]